Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2007-04-04 08:03:28


On Apr 4, 2007, at 7:59 AM, Bas van der Vlies wrote:

>> http://www.open-mpi.org/svn/building.php
>>
> Yes i get this error message:

Note the following one the building.php web page:

"Autoconf/Automake Note: Autoconf 2.59 / Automake 1.9.6 will
currently work with all branches available in the SVN repository.
Autoconf 2.60 (and higher) and Automake 1.10 (and higher) will not
work with any branch earlier than v1.2. Further, if Autoconf 2.60
(and higher) is used, Automake 1.10 (and higher) must be used."

> *** Running GNU tools
> [Running] autom4te --language=m4sh ompi_get_version.m4sh -o
> ompi_get_version.sh
> [Running] aclocal
> [Running] autoheader
> [Running] autoconf
> [Running] libtoolize --automake --copy --ltdl
> Adjusting libltdl for OMPI :-(
> -- patching for argz bugfix in libtool 1.5
> ==> your libtool doesn't need this! yay!
> -- patching 64-bit OS X bug in ltmain.sh
> ==> your libtool doesn't need this! yay!
> -- RTLD_GLOBAL in libltdl
> ==> your libltdl doesn't need this! yay!
> -- patching configure for broken -c/-o compiler test
> [Running] automake --foreign -a --copy --include-deps
> configure.ac:51: require Automake 1.10, but have 1.9.6

Based on this message^^^, it looks like you are using AC 2.60 or
later, but not using AM 1.10 or later.

> ----------------------------------------------------------------------
> ---
> It seems that the execution of "automake --foreign -a --copy
> --include-deps" has failed. See above for
> the specific error message that caused it to abort.
>
> This *MAY* be caused by an older version of one of the required
> packages. Please make sure you are using at least the following
> versions:
>
> GNU Autoconf 2.59
> GNU Automake 1.9.6
> GNU Libtool 1.5.16
> ----------------------------------------------------------------------
> ---

Note that this message is technically correct, but it does not
contain the caveat about AC 2.60 or above (although it does contain a
reference to "see above for the specific error message..."). We can
probably make it a bit more specific.

-- 
Jeff Squyres
Cisco Systems