Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Justin Bronder (jsbronder_at_[hidden])
Date: 2007-03-27 12:18:08


Having a user who requires some of the features of gfortran in 4.1.2, I
recently began building a new image. The issue is that "-mca btl gm" fails
while "-mca mtl gm" works. I have not yet done any benchmarking, as I was
wondering if the move to mtl is part of the upgrade. Below are the packages
I rebuilt.

Kernel 2.6.16.27 -> 2.6.20.1
Gcc 4.1.1 -> 4.1.2
GM Drivers 2.0.26 -> 2.0.26 (with patches for newer kernels)
OpenMPI 1.1.4 -> 1.2

The following works as expected:
/usr/local/ompi-gnu/bin/mpirun -np 4 -mca mtl gm --host node84,node83 ./xhpl

The following fails:
/usr/local/ompi-gnu/bin/mpirun -np 4 -mca btl gm --host node84,node83 ./xhpl

I've attached gziped files as suggested on the "Getting Help" section of the
website and the output from the failed mpirun. Both nodes are known good
Myrinet nodes, using FMA to map.

Thanks in advance,

-- 
Justin Bronder
Advanced Computing Research Lab
University of Maine, Orono
20 Godfrey Dr
Orono, ME 04473
www.clusters.umaine.edu