Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Brian Barrett (bbarrett_at_[hidden])
Date: 2007-03-26 16:06:13


On Mar 25, 2007, at 11:20 AM, Daniele Avitabile wrote:

> Hi everybody,
>
> I am trying to install open mpi on a Mac Os XServer, and the make
> all command exits with the error
>
> openmpi_install_failed.tar.gz
>
> as you can see from the output files I attached.
>
> Some comments that may be helpful:
>
> 1) I am not root on the machine, but I have permissions to write
> in /usr/local/applications/, which is the directory in which I want
> to install openmpi.
>
> 2) In the same directory there is already an openmpi 1.1.2
> installation, with gcc-4.0.1 compilers. I want to install the
> current version of openmpi
> and use a different compiler, namely the gcc compilers optimised
> for apple intel. They reside in the folder /usr/local/bin, and I
> pass them in the make command, as you can see from the attached file.
>
> Any idea as to why I receive that error?

Short answer:
You need to either use the system-provided GCC or rebuild your
version of GCC to use /usr/bin/libtool instead of /usr/bin/ld to link.

Long answer:
There are some things that are a little complicated to do with Mach-O
if you want library versioning and plug-ins and all that to work
properly. GNU Libtool (and therefore Open MPI) assume that if you
are using GCC, it can emit options to the linker that are meant for /
usr/bin/libtool, the library creation helper for OS X. -
compatibility_version is one of those things. Your version of GCC is
instead invoking /usr/bin/ld directly, so things are going wrong.

You can still use the "intel optimized" version of GCC to compile
your application, as long as it doesn't use GNU libtool, of course.
Just use the system GCC to compile Open MPI and all will be fine.

Hope this helps,

Brian