Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2007-03-24 08:38:43


Dan --

Your attachments didn't seem to make it through. Could you re-send?

Thanks

On Mar 23, 2007, at 7:01 PM, Dan Dansereau wrote:

> To ALL
>
> I am getting the following error while attempting to install
> openmpi on a Linux
>
> System – as follows
>
> Linux utahwtm.hydropoint.com 2.6.9-42.0.2.ELsmp #1 SMP Wed Aug 23
> 13:38:27 BST 2006 x86_64 x86_64 x86_64 GNU/Linux
>
>
>
> with the lntel compilers that are the latest versions of 9.1
>
>
>
> this is the ERROR
>
>
>
> libtool: link: icc -O3 -DNDEBUG -finline-functions -fno-strict-
> aliasing -restrict -pthread -o opal_wrapper opal_wrapper.o -Wl,--
> export-dynamic -pthread ../../../opal/.libs/libopen-pal.a -lnsl -
> lutil
>
> ../../../opal/.libs/libopen-pal.a(opal_ptmalloc2_munmap.o)(.text
> +0x1d): In function `munmap':
>
> : undefined reference to `__munmap'
>
> ../../../opal/.libs/libopen-pal.a(opal_ptmalloc2_munmap.o)(.text
> +0x52): In function `opal_mem_free_ptmalloc2_munmap':
>
> : undefined reference to `__munmap'
>
> ../../../opal/.libs/libopen-pal.a(opal_ptmalloc2_munmap.o)(.text
> +0x66): In function `mmap':
>
> : undefined reference to `__mmap'
>
> ../../../opal/.libs/libopen-pal.a(opal_ptmalloc2_munmap.o)(.text
> +0x8d): In function `opal_mem_free_ptmalloc2_mmap':
>
> : undefined reference to `__mmap'
>
> make[2]: *** [opal_wrapper] Error 1
>
> make[2]: Leaving directory `/home/dad/model/openmpi-1.2/opal/tools/
> wrappers'
>
> make[1]: *** [all-recursive] Error 1
>
> make[1]: Leaving directory `/home/dad/model/openmpi-1.2/opal'
>
> make: *** [all-recursive] Error 1
>
>
>
> the config command was
>
> ./configure CC=icc CXX=icpc F77=ifort FC=ifort --disable-shared --
> enable-static --prefix=/model/OPENMP_I
>
>
>
> and executed with no errors
>
>
>
> I have attached both the config.log and the compile.log
>
>
>
> Any help or direction would greatly be appreciated.
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
Cisco Systems