Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Brian Barrett (bbarrett_at_[hidden])
Date: 2007-03-19 13:28:14


Hi -

Thanks for the bug report. I've fixed the problem in SVN and it will
likely be part of the 1.2.1 release (whenever that happens). In the
mean time, I've attached a patch that should apply to the 1.2 tarball
that will also fix the problem.

The environment variables you want for specifying the Fortran
compilers are F77 for Fortran 77 and FC for Fortran 90/95/03.

Hope this helps,

Brian

On Mar 16, 2007, at 5:42 PM, Marius Schamschula wrote:

> Hi all,
>
> I was building open-mpi 1.2 on my G4 running Mac OS X 10.3.9 and
> had a build failure with the following:
>
> depbase=`echo runtime/ompi_mpi_preconnect.lo | sed 's|[^/]*$|.deps/
> &|;s|\.lo$||'`; \
> if /bin/sh ../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -
> I. -I. -I../opal/include -I../orte/include -I../ompi/include -I../
> ompi/include -I.. -D_REENTRANT -O3 -DNDEBUG -finline-functions -
> fno-strict-aliasing -MT runtime/ompi_mpi_preconnect.lo -MD -MP -MF
> "$depbase.Tpo" -c -o runtime/ompi_mpi_preconnect.lo runtime/
> ompi_mpi_preconnect.c; \
> then mv -f "$depbase.Tpo" "$depbase.Plo"; else rm -f
> "$depbase.Tpo"; exit 1; fi
> libtool: compile: gcc -DHAVE_CONFIG_H -I. -I. -I../opal/include -
> I../orte/include -I../ompi/include -I../ompi/include -I.. -
> D_REENTRANT -O3 -DNDEBUG -finline-functions -fno-strict-aliasing -
> MT runtime/ompi_mpi_preconnect.lo -MD -MP -MF runtime/.deps/
> ompi_mpi_preconnect.Tpo -c runtime/ompi_mpi_preconnect.c -fno-
> common -DPIC -o runtime/.libs/ompi_mpi_preconnect.o
> runtime/ompi_mpi_preconnect.c: In function
> `ompi_init_do_oob_preconnect':
> runtime/ompi_mpi_preconnect.c:74: error: storage size of `msg'
> isn't known
> make[2]: *** [runtime/ompi_mpi_preconnect.lo] Error 1
> make[1]: *** [all-recursive] Error 1
> make: *** [all-recursive] Error 1
>
> $ gcc -v
> Reading specs from /usr/libexec/gcc/darwin/ppc/3.3/specs
> Thread model: posix
> gcc version 3.3 20030304 (Apple Computer, Inc. build 1495)
>
> $ g77 -v
> Reading specs from /usr/local/lib/gcc/powerpc-apple-
> darwin7.3.0/3.5.0/specs
> Configured with: ../gcc/configure --enable-threads=posix --enable-
> languages=f77
> Thread model: posix
> gcc version 3.5.0 20040429 (experimental)
>
> (g77 from hpc.sf.net)
>
>
> Note: I had no such problem under Mac OS X 10.4.9 with my ppc and
> x86 builds. However, I did notice that the configure script did not
> detect g95 from g95.org correctly:
>
> *** Fortran 90/95 compiler
> checking for gfortran... no
> checking for f95... no
> checking for fort... no
> checking for xlf95... no
> checking for ifort... no
> checking for ifc... no
> checking for efc... no
> checking for pgf95... no
> checking for lf95... no
> checking for f90... no
> checking for xlf90... no
> checking for pgf90... no
> checking for epcf90... no
> checking whether we are using the GNU Fortran compiler... no
>
> configure --help doesn't give any hint about specifying F95.
>