Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Nader Ahmadi (a_nader_at_[hidden])
Date: 2007-02-13 09:49:26


Hello Ralph,

Thanks for clarifying that Open MPI at this point does not support AIX.
I think Open MPI has become the best implementation of MPI available in the market.
This achievement is due to hard work and dedication of all members of
OMPI development groups.
As a user I wanted to say thank you for making this technology available for everyone.

As you know three major UNIX out in the market are IBM AIX, HPUX,
and HP's Tru64( from Compaq/Digital). I was hoping that Open MPI could be
used as a common MPI across multiple UNIX, Linux and RTOS such as VxWorks plat forms.

A commitment (announced plan) from Open MPI group to make OMPI support available for major UNIX and RTOS,
will make the Open MPI the leader in the market, and could open new doors for R&D grants.

Ali,

      Ralph H Castain <rhc_at_[hidden]>
      Sent by: users-bounces_at_[hidden]
      02/08/2007 08:40 AM Please respond to
            Open MPI Users <users_at_[hidden]>

     To "Open MPI Users <users_at_[hidden]>"
            cc
            Subject Re: [OMPI users] Does Open MPI "Realy" support AIX?

            

     

Hi Ali

After conferring with my colleagues, it appears we don't have the cycles
right now to really support AIX. As you have noted, the problem is with the
io forwarding subsystem - a considerable issue.

We will revise the web site to indicate this situation. We will provide an
announcement of any change in that status.

Thanks
Ralph

On 2/7/07 1:18 PM, "Nader Ahmadi" <a_nader_at_[hidden]> wrote:

> Hello All,
>
> We are in the process to decide, if we should use Open MPI in an AIX
> environment.
>
> Our in-house testing indicates that OMPI (V 1.1.x and V 1.2.x) stdio is broken
> under AIX.
>
> At this point, I am trying to find out if there is a fix or work-around for
> this problem. I have put another
>
> posting (see attached). One recommendation was try pre-release of V 1.2, which
> didn't make any difference.
>
> I am hoping that an OMPI developer or someone from IBM come up with a
> solution.
>
> Open MPI documentation, indicates that AIX is being supported, with limited
> testing before each release.
>
> What is limited testing? Does it mean, Configure, Install and running "Hello
> World" on one node?
>
> In short, we did configure and installed V 1.1.x as well as V1.2.x, but
> attempt to running
>
> a simple test such as "mpirun -np 1 hostname", fails, see attached for more
> details.
>
> I have eight nodes IBM systems, I could run any test, to solve this problem.
>
> Thanks for your comments
>
> Ali,
>
> ------------------------------------------------------------------------------
> ---------
>
> From Previous Posting on OMPI user's group
>
> ------------------------------------------------------------------------------
> ----------------------------
>
> I have installed Open MPI 1.1.2 on IBM AIX 5.3 cluster. It looks like
>
> terminal output is broken. There are a few entry in the OpenMPI archive for
> this problem,
>
> with no suggested solution or real work around.
>
> I am putting this posting with hope to get some advise for a work around or
> solution.
>
> #mpirun -np 1 hostname
>
> No out put, piping the command to "cat" or "more" generate no out put as well.
>
> The only way to get an output from this command is to add --debug-daemons
>
> #mpirun -np 1 --debug-daemons hostname
>
> Even this debug option is not working for a real application which generate
> several output.
>
> Looking forward for any comments.
>
> Thanks
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

_______________________________________________
users mailing list
users_at_[hidden]
http://www.open-mpi.org/mailman/listinfo.cgi/users