Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

From: Matteo Guglielmi (matteo.guglielmi_at_[hidden])
Date: 2007-02-12 14:56:56


Jeff Squyres wrote:
> On Feb 12, 2007, at 2:34 PM, Matteo Guglielmi wrote:
>
>
>> Those nic "eth1" are not connected at all... all the machines use
>> only the eth0
>> interface which have different IP for each PC.
>>
>
> Gotcha. But, FWIW, OMPI doesn't know that because they have valid IP
> addresses. So it thinks they're on the same subnet (on the same
> host, actually), and therefore thinks that they should be routable.
>
>
>> Anyway you solved my problem suggesting me those FAQ entries!!!
>> --mca btl_tcp_if_exclude lo,eth1 that's the magic option which
>> works for me!!!
>>
>
> Excellent -- glad to help.
>
> Another solution might be to simply disable those NICs since they're
> not hooked up to anything; then OMPI should work without any options.
>
Yep that's even better!
> Good luck!
>
>
Thanks again,

I was playing around with the firewall so far and couldn't get any solution
out of it... and now I know why... because the problem wasn't there!!!

Oh my gosh... you helped me a lot!

Cheers,
MG.