Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2007-02-12 13:38:15


On Feb 12, 2007, at 2:34 PM, Matteo Guglielmi wrote:

> Those nic "eth1" are not connected at all... all the machines use
> only the eth0
> interface which have different IP for each PC.

Gotcha. But, FWIW, OMPI doesn't know that because they have valid IP
addresses. So it thinks they're on the same subnet (on the same
host, actually), and therefore thinks that they should be routable.

> Anyway you solved my problem suggesting me those FAQ entries!!!
> --mca btl_tcp_if_exclude lo,eth1 that's the magic option which
> works for me!!!

Excellent -- glad to help.

Another solution might be to simply disable those NICs since they're
not hooked up to anything; then OMPI should work without any options.

Good luck!

-- 
Jeff Squyres
Server Virtualization Business Unit
Cisco Systems