Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

From: Mark Kosmowski (mark.kosmowski_at_[hidden])
Date: 2007-02-08 17:51:47


I think I fixed the problem. I at least have mpirun ... hostname
working over the cluster.

The first thing I needed to do was to make the gigabit network an
internal zone in Yast ... firewall (which essentially turns off the
firewall over this interface).

Next I needed to add the -mca options as follows:

mpirun --prefix /opt/openmpi -mca oob_tcp_include eth0 -mca
btl_tcp_if_include eth0 --hostfile ~/work/openmpi_hostfile -np 4
hostname

The above command works properly without the --prefix option,
verifying that my PATH and LD_LIBRARY_PATH variables are properly set
up.

Unfortunately, I have jobs running on each machine in SMP mode that
will take the better part of this coming week to complete, so it will
be awhile before I will be able to do more than just mpirun ...
hostname.

Could a section be added to the FAQ mentioning that the firewall
service should be shutdown over the mpi interface and that the two
-mca switches should be used? This could perhaps be most useful to a
beginner in either the 'Running MPI Jobs' or 'Troubleshooting'
sections of the FAQ.

Thanks,

Mark Kosmowski