Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2007-01-24 21:00:51


You are correct -- disabling the C++ bindings caused that directory
to not get created.

I've committed a fix on the trunk. Thanks!

On Jan 24, 2007, at 1:47 PM, Audet, Martin wrote:

> Hi,
>
> I use sometimes OpenMPI and it looks like the mpicc wrapper gives
> gcc an inexistant directory with -I option. If I ask mpicc how it
> calls gcc it prints the following:
>
> [audet_at_linux15 libdfem]$ mpicc -show
> gcc -I/usr/local/openmpi-1.1.2/include -I/usr/local/
> openmpi-1.1.2/include/openmpi -pthread -L/usr/local/openmpi-1.1.2/
> lib -lmpi -lorte -lopal -ldl -Wl,--export-dynamic -lnsl -lutil -lm -
> ldl
> [audet_at_linux15 libdfem]$ ls /usr/local/openmpi-1.1.2/include /
> usr/local/openmpi-1.1.2/include/openmpi
> ls: /usr/local/openmpi-1.1.2/include/openmpi: No such file or
> directory
> /usr/local/openmpi-1.1.2/include:
> mpi.h mpif-common.h mpif-config.h mpif.h
> [audet_at_linux15 libdfem]$
>
> The directory 'usr/local/openmpi-1.1.2/include/openmpi' doesn't
> exist. And this explains the annoying warnings I get when I compile
> my sources (I like to have no warning):
>
> cc1plus: warning: /usr/local/openmpi-1.1.2/include/openmpi: No
> such file or directory
>
> This happens with OpenMPI 1.1.2 configured as follow:
>
> ./configure --prefix=/usr/local/openmpi-1.1.2 --disable-mpi-f90
> --disable-mpi-cxx --disable-cxx-exceptions --with-io-romio-
> flags=--with-file-system=ufs+nfs
>
> Thanks,
>
> Martin Audet
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
Server Virtualization Business Unit
Cisco Systems