Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

From: Audet, Martin (Martin.Audet_at_[hidden])
Date: 2007-01-24 13:47:36


Hi,

I use sometimes OpenMPI and it looks like the mpicc wrapper gives gcc an inexistant directory with -I option. If I ask mpicc how it calls gcc it prints the following:

   [audet_at_linux15 libdfem]$ mpicc -show
   gcc -I/usr/local/openmpi-1.1.2/include -I/usr/local/openmpi-1.1.2/include/openmpi -pthread -L/usr/local/openmpi-1.1.2/lib -lmpi -lorte -lopal -ldl -Wl,--export-dynamic -lnsl -lutil -lm -ldl
   [audet_at_linux15 libdfem]$ ls /usr/local/openmpi-1.1.2/include /usr/local/openmpi-1.1.2/include/openmpi
   ls: /usr/local/openmpi-1.1.2/include/openmpi: No such file or directory
   /usr/local/openmpi-1.1.2/include:
   mpi.h mpif-common.h mpif-config.h mpif.h
   [audet_at_linux15 libdfem]$

The directory 'usr/local/openmpi-1.1.2/include/openmpi' doesn't exist. And this explains the annoying warnings I get when I compile my sources (I like to have no warning):
 
   cc1plus: warning: /usr/local/openmpi-1.1.2/include/openmpi: No such file or directory

This happens with OpenMPI 1.1.2 configured as follow:

   ./configure --prefix=/usr/local/openmpi-1.1.2 --disable-mpi-f90 --disable-mpi-cxx --disable-cxx-exceptions --with-io-romio-flags=--with-file-system=ufs+nfs

Thanks,

Martin Audet