Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Brian W. Barrett (bbarrett_at_[hidden])
Date: 2007-01-16 09:37:14


Open MPI will not run on PA-RISC processors. There are some
functions in Open MPI that must be implemented in assembly.
Presently, these are only supported for:

   * Alpha (32 or 64 bit, beta support)
   * IA-32
   * IA-64
   * MIPS (n32 or 64 bit APIs only, beta support)
   * Opteron / EM64T
   * PowerPC (32 or 64 bit)
   * UltraSparc (32 or 64 bit)
   * Windows (beta support)

Any other architectures are not supported and will not work.

Brian

On Jan 15, 2007, at 10:22 AM, Jeff Squyres wrote:

> I'm unaware of anyone ever testing on HP-UX. So I don't know how
> well it will do.
>
> OMPI only has a few very-system-specific features, and there is a
> pretty comprehensive "configure" script that may be able to figure
> out all the HP-UX-isms, but I am guessing that there's going to be a
> small number of "gotchas" along the way.
>
>
> On Jan 15, 2007, at 11:12 AM, Nader Ahmadi wrote:
>
>> Hello,
>>
>> I am planning to install OpenMPI on a HPUX system. Does anyone has
>> any experience using
>> OMPI on HPUX?
>>
>> I do appreciate any comments.
>>
>> Thanks
>>
>> Nader,
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> --
> Jeff Squyres
> Server Virtualization Business Unit
> Cisco Systems
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
   Brian Barrett
   Open MPI Team, CCS-1
   Los Alamos National Laboratory