Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Grobe, Gary L. \(JSC-EV\)[ESCG] (gary.l.grobe_at_[hidden])
Date: 2007-01-05 15:28:55


This is just an FYI of the Jan 5th snapshot.

I'll send a backtrace of the processes as soon as I get a b3 running.
Between my filtered webdav svn access problems and the latest nightly
snapshots, my builds are currently failing where the same config lines
worked on previous snapshots ...

$./configure --prefix=/usr/local/openmpi-1.2b3r13006 --with-mx=/opt/mx
--with-mx-libdir=/opt/mx/lib
...

*** GNU libltdl setup
configure: OMPI configuring in opal/libltdl
configure: running /bin/sh './configure'
'--prefix=/usr/local/openmpi-1.2b3r13006' '--with-mx=/opt/mx'
'--with-mx-libdir=/opt/mx/lib' 'F77=ifort' --enable-ltdl-convenience
--disable-ltdl-install --enable-shared --disable-static
--cache-file=/dev/null --srcdir=.
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... configure: error: newly
created file is older than distributed files!
Check your system clock
configure: /bin/sh './configure' *failed* for opal/libltdl
configure: error: Failed to build GNU libltdl. This usually means that
something
is incorrectly setup with your environment. There may be useful
information in
opal/libltdl/config.log. You can also disable GNU libltdl (which will
disable
dynamic shared object loading) by configuring with --disable-dlopen.

---- end of output of /opal/libltdl/config.log ----

## ----------- ##
## confdefs.h. ##
## ----------- ##

#define PACKAGE_BUGREPORT "bug-libtool_at_[hidden]"
#define PACKAGE_NAME "libltdl"
#define PACKAGE_STRING "libltdl 2.1a"
#define PACKAGE_TARNAME "libltdl"
#define PACKAGE_VERSION "2.1a"

configure: exit 1

-----Original Message-----
Now, if you use the latest trunk, you can use the new MX BTL which
provide support for shared memory and self communications. Add "--mca
pml ob1 --mca btl mx --mca btl_mx_shared_mem 1 --mca btl_mx_self 1"
in order to activate these new features. If you have a 10G cards, I
suggest you add "--mca btl_mx_flags 2" as well.

   Thanks,
     george.

PS: Is there any way you can attach to the processes with gdb ? I would
like to see the backtrace as showed by gdb in order to be able to figure
out what's wrong there.