Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

From: Benjamin (open-mpi.org.antis_at_[hidden])
Date: 2006-12-29 15:36:59


Hello,

I'm a lam user looking to switch to openmpi, and having trouble
compiling. I hope someone here can give me a hint!

So configure works fine, as does make up to this point:

g++ -O3 -DNDEBUG -fno-inline -pthread -o .libs/ompi_info components.o
ompi_info.o output.o param.o version.o -Wl,--export-dynamic
../../../ompi/.libs/libmpi.so
/<homedir>/programs/openmpi-1.1.2/orte/.libs/liborte.so
/<homedir>/programs/openmpi-1.1.2/opal/.libs/libopal.so -ldl -lnsl
-lutil -lm -Wl,--rpath -Wl,/<homedir>/programs/openmpi/lib

components.o(.text+0xf9): In function `ompi_info::open_components()':
: undefined reference to `std::basic_string<char,
std::char_traits<char>, std::allocator<char> >::_Rep::_S_empty_rep_storage'

components.o(.text+0x118): In function `ompi_info::open_components()':
: undefined reference to `std::basic_string<char,
std::char_traits<char>, std::allocator<char> >::_Rep::_S_empty_rep_storage'

... and so on, several hundred errors complaining about a lack of
_S_empty_rep_storage in various places. This seems to be a common error
when I've done a web search, however I can find no working solutions.

Thanks in advance for any help that can be offered, no matter how small.

Cheers,
Ben.