Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Ralph Castain (rhc_at_[hidden])
Date: 2006-12-22 15:28:55


Thanks Ali. That is indeed helpful.

I personally launch using rsh (both on OSX and Linux) frequently and have no
problem with IO forwarding. So it must be something about the AIX
environment that is causing the issue.

Debug daemons should have nothing to do with the application process¹ stdio
channels. I¹ll take another look at that code and see if there is some
unexpected interaction that might be occurring.

As I said earlier, though, there is little we can do about AIX at this time
due to lack of access to that environment. If we can find someone with
access and willing to help, we will explore it further.

Ralph

On 12/22/06 11:29 AM, "Ali Eghlima" <Ali_Eghlima_at_[hidden]> wrote:

>
> Hi Ralph,
>
> Thanks for the quick reply. The launch environment is rsh. I was also puzzled,
> when I find out --debug-daemons option
> makes mpirun to work for a simple case.
>
> Thanks again
>
> Ali,
>
>
>
>
> Ralph Castain <rhc_at_[hidden]>
> Sent by: users-bounces_at_[hidden] 12/22/2006 10:49 AM
> Please respond to
> Open MPI Users <users_at_[hidden]>
> To
> Open MPI Users <users_at_[hidden]>
> cc
> Subject
> Re: [OMPI users] Open MPI 1.1.2 stdout problem with IBM AIX 5.3
>
>
>
>
> Hi Ali
>
> I have seen this reported twice now ­ I think from two different sources, but
> I could be incorrect. Unfortunately, we don¹t have access to an AIX cluster to
> investigate the problem. We don¹t see it on any other platform at this time.
>
> Could you tell me something more about your cluster? In particular, it would
> help to know your launch environment (e.g., rsh/ssh, SLURM, TM, etc.). The
> noted behavior of using ‹debug-daemons to resolve the problem has me puzzled
> as that flag only causes the daemons to keep their stdio ports open ­ it has
> nothing to do with the application processes nor the I/O forwarding subsystem.
>
> I can suggest a couple of options in the interim, though I don¹t know that
> they will solve the problem:
>
> 1. You could upgrade to the 1.2 beta release. The runtime underwent
> some significant changes that might help here; or
> 2. You could try configuring Open MPI with ³--disable-pty-support². The
> I/O forwarding system is currently based upon pty¹s. We have seen a problem on
> one other platform where the pty support wasn¹t quite what Open MPI expects ­
> disabling it solved the problem. You should first check if the 1.1.2 release
> supports this configuration option (I honestly can¹t remember ­ it has been
> too long) - you may need to upgrade to 1.2 to do this.
>
> I hope that provides some help. If/when we get access to an AIX cluster, we¹ll
> try to dig deeper into this issue.
>
> Ralph
>
>
>
> On 12/22/06 7:44 AM, "Ali Eghlima" <Ali_Eghlima_at_[hidden]> wrote:
>
>
> Hello,
>
> We have Open MPI 1.1.2 installed on IBM AIX 5.3 cluster. It looks like
> terminal output is broken. There are a few entry in the archive for this
> problem,
> with no suggested solution or real work around.
>
> I am putting this posting with hope to get some advise for a work around or
> solution.
>
>
>
> #mpirun -np 1 hostname
>
> No out put, piping the command to "cat" or "more" generate no out put
> as well.
> The only way to get an output from this command is to add
> --debug-daemons
>
> #mpirun -np 1 --debug-daemons hostname
>
> Even this debug option is not working for a real application which generate
> several output.
>
> Looking forward for any comments.
>
> Thanks
>
> Ali,
>
>
>
>
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
> <http://www.open-mpi.org/mailman/listinfo.cgi/users>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users