Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Michael John Hanby (mhanby_at_[hidden])
Date: 2006-12-19 15:53:37


Never mind, I found it in the FAQ, need version 1.2 of OpenMPI. I'll
give that a go.

-----Original Message-----
From: users-bounces_at_[hidden] [mailto:users-bounces_at_[hidden]] On
Behalf Of Michael John Hanby
Sent: Tuesday, December 19, 2006 2:28 PM
To: Open MPI Users
Subject: [OMPI users] configure openmpi with support for Sun
gridengine(SGE)?

Howdy,

I'm compiling OpenMPI 1.1.2 on a Rocks Cluster 4.2.1. The cluster has
sge installed which is what the users will use to submit their MPI jobs
(i.e. using qsub).

I'm not having any luck finding the correct parameters to provide
./configure in order to include support for SGE.

Here's the configure line that I've tried (I'm including support for
TopSpin Infiniband and using Intel compilers):

./configure CC='icc' CXX='icpc' FC='ifort' F77='ifort'
CPPFLAGS="-I/share/apps/intel/cce/include"
LDFLAGS="-L/share/apps/intel/cce/lib" --with-mvapi=/usr/local/topspin
--with-mvapi-libdir=/usr/local/topspin/lib64 --enable-static
--prefix=/share/apps/openmpi-1.1.2

Any suggestions on what I should add to ./configure to enable SGE
support?

If I run ompi_info and grep for grid, I don't see any results.

Thanks, Mike

_______________________________________________
users mailing list
users_at_[hidden]
http://www.open-mpi.org/mailman/listinfo.cgi/users