Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Ryan Thompson (ryan_at_[hidden])
Date: 2006-12-06 16:43:23


Hi Anthony,

I made some progress, however, I still get the same trace_API.h
error, although I'm not certain if it is important.

It appears that the binaries are built regardless and the
installcheck-all appears to pass on all tests.

As requested, I've attached a gzip'd tarball of my configure, make,
make install, & make installcheck-all.

Also, here are my configure arguments, as they appear in my 'do-
configure' shell script...

# MPE do.sh

JAVA="/opt/sun-jdk-1.5.0.08"
MPERUN="/opt/openmpi/bin/mpiexec -n 4"

./configure --prefix=/opt/openmpi \
         --enable-logging=yes \
         --disable-f77 \
         --enable-slog2=build \
         --enable-collchk=no \
         --enable-graphics=no \
         --with-mpicc="/opt/openmpi/bin/mpicc" \
         --with-mpiinc="-I/opt/openmpi/include" \
         --with-mpilibs="-L/opt/openmpi/lib" \
         --with-java=$JAVA

Thanks,
Ryan


--
Ryan Thompson
HPC & Systems Admin
Zymeworks, Inc.
ryan_at_[hidden]
On 5-Dec-06, at 2:37 PM, Anthony Chan wrote:
>
>
> On Tue, 5 Dec 2006, Ryan Thompson wrote:
>
>> I'm attempting to build MPE without success. When I try to make it, I
>> recieve the error:
>>
>> trace_input.c:23:23: error: trace_API.h: No such file or directory
>
> I just built the related mpe2's subpackage, slog2sdk, on a AMD64  
> (Ubuntu
> 6.06.1) with gcc-4.0 and I don't see the strange errors that you
> observed...   I put the latest mpe2 on our ftp server:
>
> ftp://ftp.mcs.anl.gov/pub/mpi/mpe/beta/mpe2-1.0.5b2.tar.gz
>
> which contains various bugfixes over mpe2-1.0.4. I have tested
> mpe2-1.0.5b2 with the openmpi-1.1.2 on an IA32 linux box,  
> everything seems
> working fine.
>
>> Where is this file supposed to come from?
>>
>> Here are my configure arguments...
>>
>> JAVA="/opt/sun-jdk-1.5.0.08"
>>
>> ./configure --prefix=/opt/mpe \
>> --sharedstatedir=/var/mpe \
>> --localstatedir=/com/mpe \
>> --enable-misc=yes \
>> --enable-logging=yes \
>> --enable-f77=no \
>> --enable-wrappers=yes \
>> --enable-slog2=build \
>> --enable-collchk=no \
>> --enable-graphics=no \
>> --with-mpicc="/opt/openmpi/bin/mpicc" \
>> --with-mpiinc="-I/opt/openmpi/include" \
>> --with-mpilibs="-L/opt/openmpi/lib" \
>> --includedir=$JAVA/include \
>> --with-java=$JAVA
>>
>
> mpe2 does not use sharedstatedir and localstatedir, so you don't need
> to specify --sharedstatedir and --localstatedir.  The only configure
> option I see problem is --includedir=$JAVA/include which will force
> mpe2 to install mpe include files to /opt/sun-jdk-1.5.0.08/include.
> I believe it is a mistake.
>
> FYI: here is my configure command to build mpe2 for openmpi:
>
> mkdir <build_mpe24openmpi>
> cd <build_mpe24openmpi>
> <mpe2-1.0.5b2>/configure CC=<C compiler to build openmpi>
>                          F77=<Fortran compiler to build openmpi>
>                          MPI_CC=<openmpi-install-dir>/bin/mpicc
>                          MPI_F77=<openmpi-install-dir>/bin/mpif90
>                          --with-java=/opt/sun-jdk-1.5.0.08
>                          --prefix=/opt/mpe
>                          MPERUN="<openmpi-install-dir>/bin/mpiexec - 
> n 4"
> make
> make install
> make installcheck-all
>
> If you don't need fortran support, don't use F77 and MPI_F77 and add
> --disable-f77.  The configure option MPERUN="..." and
> "make installcheck-all" enable a series of tests for the typical  
> features
> of MPE2.  Let me know if you see any problem.  If you do, send me the
> configure output as seen on your screen (not config.log), i.e.  
> c.txt from
> the following command
>
> With csh-like shell
> configure .... |& tee c.txt
>
> or
>
> With bourne-like shell
> configure ... | tee c.txt 2>&1
>
> A.Chan
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>