Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Galen M. Shipman (gshipman_at_[hidden])
Date: 2006-12-05 18:15:29


Brock Palen wrote:

>I was asked by mirycom to run a test using the data reliability pml.
>(dr) I ran it like so:
>
>$ mpirun --mca pml dr -np 4 ./xhpl
>
>Is this the right format for running the dr pml?
>
>
>
This should be fine, yes.
I can running HPL on our test cluster to see if something is wrong with DR.
I assume you are using GM and not MX?
Can you try running a simple ping-pong to make sure we have the basics
on this platform?
If you have access to them, running the intel test suite would also be
helpful in determining if/where we have an issue.

>Is there any gotchas on using the dr pml?
>also if the dr pml is finding errors, and is resending data, can i
>have it tell me when that happens? Like a verbose mode?
>
>
>
Unfortunately you will need to update the source and recompile, try:

Updating this file: topdir/ompi/mca/pml/dr/pml_dr.h:245:#define
MCA_PML_DR_DEBUG_LEVEL -1
And change MCA_PML_DR_DEBUG_LEVEL to 0..

>I also tried the following (just praying) That it might work,
>
>$ mpirun --mca pml dr --mca btl ^gm -np 4 ./xhpl
>
>
>
You are telling Open MPI not to use GM in this case...

>I still get no output to the screen.
>
>This is on G5 xserve, with 1.2b1 OMPI.
>
>Brock Palen
>Center for Advanced Computing
>brockp_at_[hidden]
>(734)936-1985
>
>
>_______________________________________________
>users mailing list
>users_at_[hidden]
>http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>