Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Rainer Keller (keller_at_[hidden])
Date: 2006-12-05 12:32:45


Hello Katherine,
On Tuesday 05 December 2006 18:02, Katherine Holcomb wrote:
> We are in the process of converting our clusters from MPICH to OpenMPI
> and have encountered some odd problems. For historical reasons, the
> default shell we install for users is ksh. The --profile option to
> mpirun does not work for our users under ksh. We are unsure why
> although our system administrator believes that OpenMPI may be making
> the ksh on the remote nodes believe that it's a login shell. We've
> tried both rsh and ssh. Has anybody seen anything like this?

Please try using --mca pls_rsh_assume_same_shell 0 -- to check for the shell
on the node, it should detect the ksh on the node being used from the $SHELL
env-variable.

To check, You may also use:
ssh <nodename> echo $SHELL

> There are no problems at all under bash. (I use bash and I had no
> trouble, but then started switching some users who were having MPICH
> problems and they could not get it to work unless they changed to bash.)

In case it does not detect the correct value and set the environment
variables, could You please use --mca orte_debug 1 --mca pls_rsh_debug 1 and
send the output?

Thanks,
Rainer

-- 
----------------------------------------------------------------
Dipl.-Inf. Rainer Keller       http://www.hlrs.de/people/keller
 High Performance Computing       Tel: ++49 (0)711-685 6 5858
   Center Stuttgart (HLRS)           Fax: ++49 (0)711-685 6 5832
 POSTAL:Nobelstrasse 19                 email: keller_at_[hidden]     
 ACTUAL:Allmandring 30, R.O.030            AIM:rusraink
 70550 Stuttgart