Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Lydia Heck (lydia.heck_at_[hidden])
Date: 2006-11-25 12:58:07


The configuration of openmpi-1.2b1r12657 goes fine.
When I try to build I get somewhere are into the buid the following
error message.

DEPDIR=.deps depmode=none /bin/bash ../../../../config/depcomp \
/bin/bash ../../../../libtool --tag=CC --mode=compile
/opt/studio11/SUNWspro/bin/cc -DHAVE_CONFIG_H -I. -I. -I.
./../../../opal/include -I../../../../orte/include -I../../../../ompi/include
-I../../../../ompi/include -I..
/../../.. -DNDEBUG -g -O -xtarget=opteron -xarch=amd64 -mt -c -o
common_sm_mmap.lo common_sm_mmap.c
libtool: compile: /opt/studio11/SUNWspro/bin/cc -DHAVE_CONFIG_H -I. -I.
-I../../../../opal/include -I../../../
../orte/include -I../../../../ompi/include -I../../../../ompi/include
-I../../../.. -DNDEBUG -g -O -xtarget=opt
eron -xarch=amd64 -mt -c common_sm_mmap.c -KPIC -DPIC -o .libs/common_sm_mmap.o
Assembler: common_sm_mmap.c
        "/tmp/IAAztaqgp", line 11799 : Trouble closing elf file
cc: ube failed for common_sm_mmap.c
gmake[2]: *** [common_sm_mmap.lo] Error 1
gmake[2]: Leaving directory
`/hpcconsole-1/SOFTWARE/openmpi-1.2b1r12657/ompi/mca/common/sm'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/hpcconsole-1/SOFTWARE/openmpi-1.2b1r12657/ompi'
gmake: *** [all-recursive] Error 1

I know that this is in development, but the openmpi-1.2b1
fails to run one our major codes. So I hoped that with the more
recent version I would be more successful

Lydia

------------------------------------------
Dr E L Heck

University of Durham
Institute for Computational Cosmology
Ogden Centre
Department of Physics
South Road

DURHAM, DH1 3LE
United Kingdom

e-mail: lydia.heck_at_[hidden]

Tel.: + 44 191 - 334 3628
Fax.: + 44 191 - 334 3645
___________________________________________