Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Florian Fleissner (fleissner_at_[hidden])
Date: 2006-10-31 12:08:50


Hi,

I sucessfully build and installed OpenMPI on a Debian machine running Sarge.

> uname -a
> Linux karush 2.6.11-1-686-smp #1 SMP Mon Jun 20 20:18:45 MDT 2005
i686 GNU/Linux

As I am not root, I installed OpenMPI into my home to ~/bin/OpenMPI. I
added ..../OpenMPI/bin to my PATH and ..../OpenMPI/lib to my
LD_LIBRARY_PATH.

Unfortunately ompi_info failed, complaining that it cannot find some
libraries that are obviously installed in ..../OpenMPI/lib/openmpi .
Although all installation manuals I found only require ..../OpenMPI/lib
to be added to LD_LIBRARY_PATH, I tried adding the subdirectory
..../lib/openmpi to LD_LIBRARY_PATH as well.
The result is that now the libraries seem to be found but ompi_info
still complains about the libraries to have "invalid ELF header" (see
attached output of ompi_info).

Is there anything that I have to configure additionally to make it run?
Unfortunately I am not familiar with libtool's load mechanism for .la libs.

Thanks for any help in advance.

Yours
Florian Fleissner

-- 
---------------------------------------------------
   Dipl.-Ing. Florian Fleißner
   Institut für Technische und Numerische Mechanik
   Universität Stuttgart
   Pfaffenwaldring 9
   70550 Stuttgart
   Deutschland
   Zimmer: 4.120
   Tel: 0711/685-66395, Fax 685-66400
   URL: http://www.itm.uni-stuttgart.de
   email: fleissner_at_[hidden]
---------------------------------------------------


  • application/x-compressed attachment: ompi.tgz