Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Durga Choudhury (dpchoudh_at_[hidden])
Date: 2006-10-27 10:16:56


Calin

You do not need to be root to do this. Just add the following line to your
.bashrc file, located in your home directory. (or an equivalent file if you
are not a bash user):

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib
(if you ran ./configure with a --prefix option, then use $prefix/lib instead
of /usr/local/lib)

Start another shell after you have saved this file. Your problem should go
away. BTW, every user of your cluster has to do this in his/her ~/.bashrc
file. This has nothing to do with the root account.

Good luck.
Durga

On 10/27/06, calin pal <calin.fc_at_[hidden]> wrote:
>
> sir,
> i have seen the problem according to u r suggestion.but sir
> the actual roblem i m facing that.............
> in our college lab i have installed openmpi-1.1.1 tar.gz
> in four computers
> from root using root password................
> (now i am doing program in local user...)
> so sir, if i have to give some value to LD_LIBRARY_PATH for
> that
> again i have to go to root or i can access from user also....
> because in our college we dont have NFS......
> or sir, from root again i have to install openmpi -1.1.1
> tar.gz
> then i have to set LD_LIBRARY_PATH...
> so plz sir tell me the actual solution.......
> what is the solution??????
>
> calin
> fergusson college,pune
> india
> msc.tech(maths &comp.sc)
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>

-- 
Devil wanted omnipresence;
He therefore created communists.