Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Galen Shipman (gshipman_at_[hidden])
Date: 2006-10-06 14:42:34


Brian,

Are you compiling on a 64 bit platform that has both 64 and 32 bit gm
libraries? If so you probably have a libgm.la that is mucking things
up. Try modifying you configure line as follows:

> ./configure --with-gm=/opt/gm --with-tm=/usr/pbs --disable-shared
> --enable-static CC=pgcc CXX=pgCC F77=pgf77 FC=pgf90 FFLAGS=-fastsse
> FCFLAGS=-fastsse LDFLAGS=-L/opt/gm/lib64

Thanks,

Galen

On Oct 6, 2006, at 12:27 PM, Andrus, Mr. Brian ((Contractor)) wrote:

>
> Ok, I am getting an error when I run make after configuring with the
> following options:
> ./configure --with-gm=/opt/gm --with-tm=/usr/pbs --disable-shared
> --enable-static CC=pgcc CXX=pgCC F77=pgf77 FC=pgf90 FFLAGS=-fastsse
> FCFLAGS=-fastsse
>
> It aborts after a bit with:
> /opt/gm/lib/libgm.so: could not read symbols: File in wrong format
>
> The config.out and make.out are attached fwiw.
>
> Has anyone seen this before?
>
>
> Brian Andrus
> QSS Group, Inc.
> Naval Research Laboratory
> Monterey, California
> Desk: 831-656-4839
> <make.out.tgz>
> <config.out.tgz>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users