Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Andrus, Mr. Brian \(Contractor\) (brian.andrus_at_[hidden])
Date: 2006-10-05 12:05:18


Ok, I am having some trouble getting the RPM to compile when I add
PBSPro.
I have been able to successfully create it with Myrinet and using PGI
compilers.

Now getting it to package up with PBSPro is another story. It looks like
it compiles fine, but the packaging may be the issue. I thought I should
post here to see if anyone has already been down this path.

When I use:
rpmbuild --rebuild --define configure_options" --with-gm=/opt/gm
--disable-shared --with-tm=/usr/pbs CC=pgcc CXX=pgCC F77=pgf77 FC=pgf90
FFLAGS=-fastsse FCFLAGS=-fastsse " ./openmpi-1.1.1-1.src.rpm

I eventually get:
.
.
make[2]: Entering directory `/usr/src/redhat/BUILD/openmpi-1.1.1'
make[2]: Nothing to be done for `install-exec-am'.
make[2]: Nothing to be done for `install-data-am'.
make[2]: Leaving directory `/usr/src/redhat/BUILD/openmpi-1.1.1'
make[1]: Leaving directory `/usr/src/redhat/BUILD/openmpi-1.1.1'
+ rm -f /var/tmp/openmpi-1.1.1-1-root//usr/bin/openmpi
+ rm -f /var/tmp/openmpi-1.1.1-1-root//usr/bin/orteconsole
+ rm -f /var/tmp/openmpi-1.1.1-1-root//usr/bin/orteprobe
+ find /var/tmp/openmpi-1.1.1-1-root -type f -o -type l
+ sed -e s@/var/tmp/openmpi-1.1.1-1-root@@
+ egrep 'lib.*.so|mca.*so'
error: Bad exit status from /var/tmp/rpm-tmp.30796 (%install)

RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.30796 (%install)

Brian Andrus
QSS Group, Inc.
Naval Research Laboratory
Monterey, California
Desk: 831-656-4839