Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Paul Fons (paul-fons_at_[hidden])
Date: 2006-09-07 01:21:51


   I solved my own question the other day regarding a openmpi job
running in parallel on my own g5 computer and failing on a remote.
The problem apparently has to do with the fact there are two NICs in
the remote machine. By specifying a command line like:

mpiexec --mca btl_tcp_if_include en0 -np 4 /opt/feff/feff85/ffmod2

I was able to get my job running on the remote machine just fine (and
a nice speed up too!). I am puzzled why I can't put this option (to
force the use of the en0 NIC) in the startup file ~/.openmpi/mca-
params.conf. In this file, I have the lines

btl_base_include=tcp,sm,self
btl_tcp_if_include=en0
rds_hostfile_path = /Users/paulfons/Ports/openmpi-1.1.1/machinefile

and yet when I drop the --mca parameter setting option from the
command line, the mpiexec command hangs exactly as it did before when
I didn't have the interface specified at all. The machinefile is
being read so I believe the config file is being read. Any ideas?

I would be happy if I could just solve this problem, but I do have
another (more complicated) question. Soon I will have yet another
remote machine (a new "woodcrest" quad core macintosh) to connect
to. The two remote machines have two NICs. Routine communications
are set within the OS to use en0 (ethernet 0). I would like openmpi
to use en1 on the remote boxes and en0 on my main box (dual 3 GHz
G5's) as I only have a single NIC on the main box. To put it in
other words, how can I specify a preferred interface on each box
(hopefully not all from the command line!).

                        Thanks.



  • application/pkcs7-signature attachment: smime.p7s