Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Durga Choudhury (dpchoudh_at_[hidden])
Date: 2006-08-28 11:21:17


Hi Miguel

Two comments on your comments:

1. Defining LD_LIBRARY_PATH should not be necessary in my case because the
libraries are in /usr/local/lib, a standard place for ld to look for shared
libs. I did not define PATH either and Linux is able to find the executable
MPI binaries in /usr/local/bin because it is a standard location for Linux.

2. I defined LD_LIBRARY_PATH (regardless of whether it should be necessary)
manually, like this:

bash: export LD_LIBRARY_PATH=/usr/local/lib

If this would have worked, I could have added this to my .bashrc

Again, any help is deeply appreciated.

Thanks
Durga

On 8/28/06, Miguel Figueiredo Mascarenhas Sousa Filipe <
miguel.filipe_at_[hidden]> wrote:
>
> Hi there,
>
> On 8/27/06, Durga Choudhury <dpchoudh_at_[hidden]> wrote:
> >
> > Hi all
> >
> > I am getting an error (details follow) in the simplest of the possible
> > test scenarios:
> >
> > Two identical regular Dell PCs connected back-to-back via an ethernet
> > switch on the 10/100 ethernet. Both run Fedora Core 4. Identical version (
> > 1.1) of Open MPI is compiled and installed on both of them *without* a
> > --prefix option ( i.e. installed on the default location of /usr/local).
> >
> > The hostfile on both the machine is the same:
> >
> > cat ~/hostfile
> >
> > 192.168.22.29
> > 192.168.22.103
> >
> > I can run openMPI on either of these two machines by forking two
> > processes:
> >
> > mpirun -np2 osu_acc_latency <------ This runs fine on either of the two
> > machines.
> >
> > However, when I try to luch the same program across the two machines, I
> > get an error:
> >
> > mpirun --hostfile ~/hostfile -np2 /home/durga/openmpi-1.1
> > /osu_benchmarks/osu_acc_latency
> >
> > durga_at_192.168.22.29's <durga_at_192.168.22.29%27s> password: foobar
> > /home/durga/openmpi-1.1/osu_benchmarks/osu_acc_latency: error while
> > loading shared libraries: libmpi.so.0: cannot open shared object file:
> > No such file or directory.
> >
> > However, the file *does exist* in /usr/local/lib:
> >
> > ls -l /usr/local/lib/libmpi.so.0
> > libmpi.so.0 -> libmpi.so.0.0.0
> >
> > I have also tried adding /usr/local/lib to my LD_LIBRARY_PATH on *both*
> > machines, to no avail.
> >
>
>
> first of: I'm not from the openMPI team.
> Where did you add your LD_LIBRARY_PATH ?
> make shure it is in one of the profile files for your shell.. such has:
> .bash_profile and _not_ .bashrc
>
> that's a tipical error in these kind of configurations..
>
> best regards
>
>
> Any help is greatly appreciated.
>
> Thanks
>
> Durga
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
>
>
> --
>
> Miguel Sousa Filipe
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>

-- 
Devil wanted omnipresence;
He therefore created communists.