Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Hugh Merz (merz_at_[hidden])
Date: 2006-08-18 17:19:34


On Fri, 18 Aug 2006, Steven A. DuChene wrote:
> I am attempting to build OpenMPI-1.1 on a RHEL4u2 system that has
> the standard gfortran install as part of the distro and with a self installed
> recent version of g95 from g95.org but when I use the FC flag to
> configure to tell it where to find the g95 executable I get a message
> during the configure run of
>
> *** Fortran 90/95 compiler
> checking whether we are using the GNU Fortran compiler... yes
> checking whether /app/g95-newer/g95-install/bin/x86_64-unknown-linux-gnu-g95 accepts -g... yes
> checking if Fortran compiler works... yes
> checking whether gfortran and /app/g95-newer/g95-install/bin/x86_64-unknown-linux-gnu-g95 compilers are compatible... no
> configure: WARNING: *** Fortran 77 and Fortran 90 compilers are not link compatible
> configure: WARNING: *** Disabling MPI Fortran 90/95 bindings
> checking if Fortran 90 compiler supports LOGICAL... skipped
> checking if Fortran 90 compiler supports INTEGER... skipped
> checking if Fortran 90 compiler supports INTEGER*1... skipped
> checking if Fortran 90 compiler supports INTEGER*2... skipped
> checking if Fortran 90 compiler supports INTEGER*4... skipped
> checking if Fortran 90 compiler supports INTEGER*8... skipped
> checking if Fortran 90 compiler supports INTEGER*16... skipped
> checking if Fortran 90 compiler supports REAL... skipped
> checking if Fortran 90 compiler supports REAL*4... skipped
> checking if Fortran 90 compiler supports REAL*8... skipped
> checking if Fortran 90 compiler supports REAL*16... skipped
> checking if Fortran 90 compiler supports DOUBLE PRECISION... skipped
> checking if Fortran 90 compiler supports COMPLEX... skipped
> checking if Fortran 90 compiler supports COMPLEX*8... skipped
> checking if Fortran 90 compiler supports COMPLEX*16... skipped
> checking if Fortran 90 compiler supports COMPLEX*32... skipped
> checking if Fortran 90 compiler supports DOUBLE COMPLEX... skipped
>
> I am not specifying any particular FCFLAGS but from searching through the mailing
> lists I am pretty sure I should be but I just don't know what exactly.
>
> Any info on this anywhere?

Compiler incompatibility is hinted at in this FAQ entry:

    http://www.open-mpi.org/faq/?category=sysadmin#multiple-installs

Try setting the F77 environment variable to use g95 for Fortran 77 compiler as well.

If you don't need F77 bindings, then supply '--disable-f77' to configure and it should build fine.

Hugh