Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Donald Kerr (Don.Kerr_at_[hidden])
Date: 2006-08-10 18:40:46

So I guess what I am really asking is, what is expected and what is the

What I am hearing is that the trigger is if the btl stack (libraries
drivers and so on) is available it will be loaded, attempted to use and
if there is a problem a message like I show below is expected.

If the btl stack is not available no attempt to load and no message is

So what I am seeing is expected behavior.


Andrew Friedley wrote On 08/10/06 17:44,:

> Donald Kerr wrote:
>> Hey Andrew I have one for you...
>> I get the following error message on a node that does not have any IB
>> cards
>> --------------------------------------------------------------------------
>> [0,1,0]: uDAPL on host burl-ct-v40z-0 was unable to find any NICs.
>> Another transport will be used instead, although this may result in
>> lower performance.
>> --------------------------------------------------------------------------
>> but I don't see this for the openib btl. Why udapl and not openib? Am
>> I missing something?
> Don't think I have enough information. You have an OpenIB stack
> installed on the system, and the openib BTL is getting loaded? If
> there's no loadable openib BTL, you wouldn't see this error message
> coming from it.
> Looking at the code, you should see a similar error from both,
> assuming both BTLs are present.
> Andrew
>> -DON