Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Manav Bhatia (manav_at_[hidden])
Date: 2006-08-05 19:59:09


I am replying to my own posting here (see below).

The -pedantic option was leading to this error. The code works fine
without this option.
However, I am wondering if this should be an issue or not.

Thanks
Manav

On Aug 5, 2006, at 3:35 PM, Manav Bhatia wrote:

> Hi,
>
> I am using OpenMPI 1.1 on Mac OS 10.4.7 with intel processors.
> I compiled and installed using the following options:
>
> /configure --prefix=/usr/local/openmpi --disable-mpi-f77 --disable-
> mpi-f90
>
> Everything compiles and runs fine in optimized mode using mpic++,
> however, I get the following compilation error message when
> compiling in debug mode
>
> /usr/local/openmpi/include/mpi.h:147: error: ISO C++ does not
> support 'long long'
>
> I am using the following compiler options in optimized mode
>
> -DNDEBUG -fno-common -O2 -felide-constructors -funroll-loops -
> fstrict-aliasing -Wdisabled-optimization
>
> and the following in debug mode
>
> -DDEBUG -fno-common -O0 -felide-constructors -g -ansi -pedantic -W -
> Wall -Wunused -Wpointer-arith -Wimplicit -Wformat -Wparentheses -
> Woverloaded-virtual -D_GLIBCXX_DEBUG -D_GLIBCXX_DEBUG_PEDANTIC
>
> Kindly help me understand what is happening here, and how I could
> resolve this error. Please let me know if I could help you with
> more information about this.
>
> Thanks
> Manav