Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Ralph H Castain (rhc_at_[hidden])
Date: 2006-08-03 10:46:42


Depending upon what version you are using, this could be resolved fairly
simply. Check to see if your version supports the "nooversubscribe" command
line option. If it does, then setting that option may (I believe) resolve
the problem - at the least, it will only allow you to run one application
process on each node the allocation you described. If you were to give -np =
2*x, you would get an error and the job would not be run.

Ralph

On 8/3/06 7:47 AM, "Martin Schafföner"
<martin.schaffoener_at_[hidden]> wrote:

> Hi all,

I noticed by accident that if I allocate only 1 of 2 CPUs on, say, x
> nodes
with PBS, it is possible to run mpiexec with -np = 2*x, i.e. I can use
> both
CPUs on each SMP node. This is not would I would expect or want. I would
>
guess that this is due to the fact that even if the _one_ orted launched
>
through PBS' TM interface can launch as many processes as you like which is
>
not the case if one would launch MPI processes directly through the TM
>
interface. How can this behavior be fixed?

Regards,

-- 
Martin
> Schafföner
Cognitive Systems Group, Institute of Electronics, Signal
> Processing and 
Communication Technologies, Department of Electrical
> Engineering, 
Otto-von-Guericke University Magdeburg
Phone: +49 391
> 6720063
PGP-Public-Key:
> http://ca.uni-magdeburg.de/certs/pgp0Cschaffoener64D8BEC0.asc
_______________
> ________________________________
users mailing
> list
users_at_[hidden]
http://www.open-mpi.org/mailman/listinfo.cgi/users