Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2006-07-31 11:09:51


On 7/26/06 10:51 AM, "Borenstein, Bernard S"
<bernard.s.borenstein_at_[hidden]> wrote:

> ld: Warning: size of symbol `mpi_fortran_argv_null_' changed from 1 in
> chimera/discmo.o to 16 in
> /home/bsb3227/openmpi_1.1.1b3/lib/libmpi.a(test_constants_f.o)
> ld: Warning: size of symbol `mpi_fortran_argvs_null_' changed from 4 in
> chimera/discmo.o to 16 in
> /home/bsb3227/openmpi_1.1.1b3/lib/libmpi.a(test_constants_f.o)
> ld: Warning: size of symbol `mpi_fortran_status_ignore_' changed from 20
> in chimera/discmo.o to 16 in
> /home/bsb3227/openmpi_1.1.1b3/lib/libmpi.a(test_constants_f.o)
> ld: Warning: size of symbol `mpi_fortran_errcodes_ignore_' changed from
> 4 in chimera/discmo.o to 16 in
> /home/bsb3227/openmpi_1.1.1b3/lib/libmpi.a(test_constants_f.o)

Rats. It took me several days of hunting, but I finally figured this one
out. It seems like this only showed up in static builds of some compilers
(intel and gfortran, in my testing).

This is due to something we introduced in 1.1b3 as a fix for OSX. It's a
long, horrid story of Fortran, linkers, and bears.

I committed a fix to the trunk at r11057, and included a lengthy log message
explaining what I did to fix the problem
(https://svn.open-mpi.org/trac/ompi/changeset/11057). It works on all the
configurations that I could try -- could you verify that it works for you?
Here's what I tested (static and dynamic builds for all):

- Linux
  - AMD, gfortran 4.0
  - AMD, intel 9.0
  - AMD, pgi 6.1
  - AMD, pathscale 2.3
- OSX
  - x86, gfortran 4.2

-- 
Jeff Squyres
Server Virtualization Business Unit
Cisco Systems