Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Dan Lipsitt (danlipsitt_at_[hidden])
Date: 2006-07-28 16:55:24


 get the following error when I attempt to run an mpi program (called
"first", in this case) across several nodes (it works on a single
node):

$ mpirun -np 3 --hostfile /tmp/nodes ./first
./first: error while loading shared libraries: libmpi.so.0: cannot
open shared object file: No such file or directory

My library path looks okay and I am able to run other programs,
including listing the supposedly missing library:

$ echo $LD_LIBRARY_PATH
/opt/openmpi/1.1/lib/
$ mpirun -np 3 --hostfile /tmp/nodes uptime
 16:42:51 up 22 days, 3:14, 10 users, load average: 0.01, 0.02, 0.04
 19:49:32 up 1:36, 0 users, load average: 0.00, 0.00, 0.00
 19:40:01 up 1:37, 0 users, load average: 0.00, 0.00, 0.00
$ mpirun -np 3 --hostfile /tmp/nodes ls -l /opt/openmpi/1.1/lib/libmpi.so*
lrwxrwxrwx 1 root root 15 Jul 13 15:44
/opt/openmpi/1.1/lib/libmpi.so -> libmpi.so.0.0.0
lrwxrwxrwx 1 root root 15 Jul 13 15:44
/opt/openmpi/1.1/lib/libmpi.so.0 -> libmpi.so.0.0.0
-rwxr-xr-x 1 root root 6157698 Jul 12 18:08
/opt/openmpi/1.1/lib/libmpi.so.0.0.0
lrwxrwxrwx 1 root root 15 Jul 26 16:17
/opt/openmpi/1.1/lib/libmpi.so -> libmpi.so.0.0.0
lrwxrwxrwx 1 root root 15 Jul 26 16:17
/opt/openmpi/1.1/lib/libmpi.so.0 -> libmpi.so.0.0.0
-rwxr-xr-x 1 root root 6157698 Jul 12 18:08
/opt/openmpi/1.1/lib/libmpi.so.0.0.0
lrwxrwxrwx 1 root root 15 Jul 26 13:50
/opt/openmpi/1.1/lib/libmpi.so -> libmpi.so.0.0.0
lrwxrwxrwx 1 root root 15 Jul 26 13:50
/opt/openmpi/1.1/lib/libmpi.so.0 -> libmpi.so.0.0.0
-rwxr-xr-x 1 root root 6157698 Jul 12 18:08
/opt/openmpi/1.1/lib/libmpi.so.0.0.0

Any suggestions?

Thanks,
Dan