Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Michael Kluskens (mklus_at_[hidden])
Date: 2006-07-26 08:36:38


Summary: You have to properly uninstall OpenMPI 1.0.2 before
installing OpenMPI 1.1

On Jul 26, 2006, at 7:05 AM, <robertmcbroom_at_[hidden]> wrote:

> Updated to open_mpi-1.1. I get a runtime error on the application as
> follows
>
> mca:base:component_find:unable to
> open:/usr/local/lip/openmpi/mca_pml_teg.so:undefined
> symbol:mca_ptl_base_modules_initialized
>
> Open_mpi is compile with g95 and gcc 4.0.3

I use that combination all the time on OS X 10.4.7 and under Debian
Sarge.

Since you did not specify how you updated to OpenMPI 1.1 I'm copying
the instructions posted previously on the list:

On Jun 26, 2006, at 5:56 PM, Benjamin Landsteiner wrote:
> Strange. I had actually done this before I emailed (several times,
> in fact), but for the sake of completeness, I did it once more. This
> time, it worked! No clue why it worked this time around.
>
> For those of you who in the future come across this problem, here are
> the (more or less exact) steps I took to recover from the problem:
>
> PROBLEM: You installed v1.1 of Open MPI and experience keyval parse
> errors upon running mpicc, mpif77, mpic++, and so forth.
>
> SOLUTION:
> 1. Go to your v1.1 directory, and type './configure' if you have not
> already done so
> 2. Type 'make uninstall'
> 3. Go to your v1.0.2 directory, and reconfigure using the same
> settings as you installed with (if you still have the install
> directory, you probably don't need to do this as it has already been
> configured)
> 4. In the v1.0.2 directory, type 'make uninstall'
> 5. For good measure, I went back to the v1.1 directory and typed
> 'make uninstall' again
> 6. Find lingering Open MPI directories and files and then delete
> them (for instance, empty Open MPI-related folders remained in my /
> usr/local/* directories)
> 7. At this point, I restarted my machine. Not sure if it's
> necessary or not.
> 8. Go back to the v1.1 directory. Type 'make clean', then
> reconfigure, then recompile and reinstall
> 9. Things should work now.
>
>
> Thank you Michael,
> ~Ben
>
> +--------------------+
> Benjamin Landsteiner
> landstei_at_[hidden]
>
> On 2006/06/26, at 3:48 PM, Michael Kluskens wrote:
>
>> You may have to properly uninstall OpenMPI 1.0.2 before installing
>> OpenMPI 1.1
>>
>> This was an issue in the past.
>>
>> I would recommend you go into your OpenMPI 1.1 directory and type
>> "make uninstall", then if you have it go into your OpenMPI 1.0.2
>> directory and do the same. If you don't have a directory with
>> OpenMPI 1.0.2 configured already then either rebuild OpenMPI 1.0.2 or
>> go into /usr/local and identify all remaining OpenMPI directories and
>> components and remove them. Basically you should find directories
>> modified when you installed OpenMPI 1.1 (or when you uninstalled it)
>> and you may find components dated from when you installed OpenMPI
>> 1.0.2.
>>
>> Michael
>>
>> On Jun 26, 2006, at 4:34 PM, Benjamin Landsteiner wrote:
>>
>>> Hello all,
>>> I recently upgraded to v1.1 of Open MPI and ran into a problem
>>> on my
>>> head node that I can't seem to solve. Upon running mpicc, mpiCC,
>>> mpic++, and so forth, I get an error like this:
>>