Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2006-07-20 00:04:22


On 7/18/06 7:33 PM, "Warner Yuen" <wyuen_at_[hidden]> wrote:
 
> USING GCC 4.0.1 (build 5341) with and without Intel Fortran (build
> 9.1.027):

What version of Open MPI were you working with? If it was a developer/SVN
checkout, what version of the GNU Auto tools were you using?
 
> Config #2: ./configure --disable-shared --enable-static --with-rsh=/
> usr/bin/ssh
> Successful Build = NO
> Error:
> g++ -O3 -DNDEBUG -finline-functions -Wl,-u -Wl,_munmap -Wl,-
> multiply_defined -Wl,suppress -o ompi_info components.o ompi_info.o
> output.o param.o version.o -Wl,-bind_at_load ../../../ompi/.libs/
> libmpi.a /Users/wyuen/mpi_src/openmpi-1.1/orte/.libs/liborte.a /Users/
> wyuen/mpi_src/openmpi-1.1/opal/.libs/libopal.a -ldl
> /usr/bin/ld: Undefined symbols:
> _mpi_fortran_status_ignore_
> _mpi_fortran_statuses_ignore_

Do you have a fortran compiler at all? If so, which one? Please send the
full output from configure, config.log, and the output from make (stdout and
stderr).

> USING Intel C (build 9.1.027) and with and without Intel Fortran
> (build 9.1.027)
>
> Config #4: ./configure --disable-mpi-f77 --disable-mpi-f90 --with-
> rsh=/usr/bin/ssh
> Successful Build = NO
> Error:
> IPO link: can not find "1"
> icc: error: problem during multi-file optimization compilation (code 1)
> make[2]: *** [libopal.la] Error 1
> make[1]: *** [all-recursive] Error 1
> make: *** [all-recursive] Error 1

This *looks* like a libtool problem. Can you send the full configure
output, config.log, and full output from "make"?
 
> Config #6: ./configure --disable-shared --enable-static --with-rsh=/
> usr/bin/ssh
> Successful Build = NO
> Error:
> _mpi_fortran_statuses_ignore_

I suspect that this is the same problem as #2.

-- 
Jeff Squyres
Server Virtualization Business Unit
Cisco Systems