Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Sven Stork (stork_at_[hidden])
Date: 2006-07-19 10:35:07


Dear Paul,

this previously posted "tutorial" how to build ParaView could maybe useful to
you:

http://www.open-mpi.org/community/lists/users/2006/05/1246.php

regards,
Sven

On Wednesday 19 July 2006 14:57, Paul Heinzlreiter wrote:
> Hi all,
>
> I'm not sure whether this bug has already been reported/fixed (maybe in
> the v1.1.1 pre-release):
>
> I've compiled and installed Open MPI Version 1.1 (stable), which worked
> well.
>
> for configuring OpenMPI I used the commandline
>
> ./configure --prefix=/home/ph/local/openmpi --disable-mpi-f77
> --disable-mpi-f99
>
> since i don't need fortran support.
>
> Compiling and executing a simple MPI test program (in C) with Open MPI
> also worked well.
>
> After that I tried to compile VTK (http://www.vtk.org) with MPI support
> using OpenMPI.
>
> The compilation process issued the following error message:
>
> /home/ph/local/openmpi/include/mpi.h:1757:33: ompi/mpi/cxx/mpicxx.h: No
> such file or directory
>
> and indeed the location of the file mpicxx.h is
> /home/ph/local/openmpi/include/openmpi/ompi/mpi/cxx/mpicxx.h
>
> and in mpi.h
>
> it is stated
>
> #if !defined(OMPI_SKIP_MPICXX) && OMPI_WANT_CXX_BINDINGS && !OMPI_BUILDING
> #if defined(__cplusplus) || defined(c_plusplus)
> #include "ompi/mpi/cxx/mpicxx.h"
> #endif
> #endif
>
> so this would refer to the file
>
> /home/ph/local/openmpi/include/ompi/mpi/cxx/mpicxx.h
>
> as I see it.
>
> so there is one subdirectory missing (openmpi) in the reference within
> mpi.h.
>
> Regards,
> Paul Heinzlreiter
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>