Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Caird, Andrew J (acaird_at_[hidden])
Date: 2006-07-17 15:08:40


That's excellent, thanks.

--andy
  

> -----Original Message-----
> From: users-bounces_at_[hidden]
> [mailto:users-bounces_at_[hidden]] On Behalf Of Jeff Squyres
> (jsquyres)
> Sent: Monday, July 17, 2006 2:08 PM
> To: Open MPI Users
> Subject: Re: [OMPI users] TM fixes on trunk
>
> For lack of a longer explanation, let's call it "internal
> accounting errors" :-). In an attempt to speed up the TM
> launcher, we made some changes in Open MPI 1.1 which ended up
> using the TM API the wrong way.
> So it was clearly a bug. It *might* work in 1.1, but I
> wouldn't recommend it (i.e., it's a timing issue -- sometimes
> it might work, sometimes it might not).
>
> More specifically -- if it's working for you, then it will
> probably continue to work for you.
>
> There is a 1.1.1b2 tarball currently available
> (http://www.open-mpi.org/software/ompi/v1.1/), and there are
> nightly snapshots of the 1.1 branch available as well
> (http://www.open-mpi.org/nightly/v1.1/).
>
> You can see a full list of the changes in the 1.1 branch in
> the "1.1.1"
> section of NEWS:
>
> http://svn.open-mpi.org/svn/ompi/trunk/NEWS
>
>
> > -----Original Message-----
> > From: users-bounces_at_[hidden]
> > [mailto:users-bounces_at_[hidden]] On Behalf Of Caird, Andrew J
> > Sent: Monday, July 17, 2006 11:10 AM
> > To: Open MPI Users
> > Subject: Re: [OMPI users] TM fixes on trunk
> >
> > Jeff,
> >
> > What were the details of the problem/fixes?
> >
> > Is it worth us moving to the trunk or using what we have
> until 1.1.1
> > arrives?
> >
> > Thanks.
> > --andy
> >
> >
> > > -----Original Message-----
> > > From: users-bounces_at_[hidden]
> > > [mailto:users-bounces_at_[hidden]] On Behalf Of Jeff Squyres
> > > (jsquyres)
> > > Sent: Monday, July 17, 2006 10:22 AM
> > > To: Open MPI Users
> > > Subject: [OMPI users] TM fixes on trunk
> > >
> > > All --
> > >
> > > Martin Schaffoner reported some TM problems to this list a little
> > > while ago. It took a long time for he and I to synch up, but we
> > > finally identified and fixed the problem. This only affects Open
> > > MPI 1.1 installs -- it is not an issue for 1.0.x
> installs. The fix
> > > has been included in both the trunk and the 1.1 branch,
> and will be
> > > included in the upcoming
> > > 1.1.1 release.
> > >
> > > --
> > > Jeff Squyres
> > > Server Virtualization Business Unit
> > > Cisco Systems
> > >
> > > _______________________________________________
> > > users mailing list
> > > users_at_[hidden]
> > > http://www.open-mpi.org/mailman/listinfo.cgi/users
> > >
> >
> > _______________________________________________
> > users mailing list
> > users_at_[hidden]
> > http://www.open-mpi.org/mailman/listinfo.cgi/users
> >
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>