Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Daryl W. Grunau (dwg_at_[hidden])
Date: 2006-07-11 15:03:08


> Message: 2
> Date: Tue, 11 Jul 2006 12:23:16 -0400
> From: George Bosilca <bosilca_at_[hidden]>
> Subject: Re: [OMPI users] OMPI 1.1 build failure with Intel 9.0
> To: Open MPI Users <users_at_[hidden]>
> Message-ID: <507769B7-8495-478B-B9A8-18982665346B_at_[hidden]>
> Content-Type: text/plain; charset=US-ASCII; delsp=yes; format=flowed
>
> I'm using the Intel compiler 9.0 on several platforms to compile Open
> MPI. I never get such kind of errors. I look into the attached file
> and I notice 2 things. First, there is a -m64 flag on the command
> line, and icc complain about not knowing anything about it (and it's
> right). Second, at the end of the file, it complain about a missing
> symbol (gxx_personality). I doubt that icc should know anything about
> the gxx_personality. In fact it look like icc is trying to use some
> libraries compiled with g++. Can you check the library path used by
> your compiler ?
>
> Thanks,
> george.

George, my problem was solved by the fix below. I didn't realize the
difference between icc and icpc - thanks Bernie!

Daryl

> Date: Tue, 11 Jul 2006 09:11:26 -0700
> To: <dwg_at_[hidden]>
> Subject: problem buiding openmpi 1.1
>
> Daryl,
>
> You need to set the C++ compiler to icpc, not icc for things to work.
>
> Bernie Borenstein
> The Boeing Company
>