Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Daryl W. Grunau (dwg_at_[hidden])
Date: 2006-07-11 11:53:02


I'm trying to build version 1.1 with Intel 9.0 compilers and getting an
error at the very end in the tools directory: ompi/tools/ompi_info. The
build appears to die with undefined references to things that belong to the
C++ string class (see long attachment). Strange thing is that this same
code compiles fine with the GNU compilers (FC3), PGI (6.1) and Pathscale (2.4).
FWIW, my arch is x86_64 ... I wrote a simple hello.cc program that used
the string class and it also compiled/linked/executed fine with icc.
Anyone else seeing this problem or is my compiler not installed correctly?
TIA,

Daryl

P.s. Here's my configure line from config.log:

  $ ./configure --build=x86_64-redhat-linux-gnu --host=x86_64-redhat-linux-gnu --target=x86_64-redhat-linux-gnu --program-prefix= --prefix=/opt/OpenMPI/openmpi-intel-1.1/ib --exec-prefix=/opt/OpenMPI/openmpi-intel-1.1/ib --bindir=/opt/OpenMPI/openmpi-intel-1.1/ib/bin --sbindir=/opt/OpenMPI/openmpi-intel-1.1/ib/sbin --sysconfdir=/etc --datadir=/opt/OpenMPI/openmpi-intel-1.1/ib/share --includedir=/opt/OpenMPI/openmpi-intel-1.1/ib/include --libdir=/opt/OpenMPI/openmpi-intel-1.1/ib/lib64 --libexecdir=/opt/OpenMPI/openmpi-intel-1.1/ib/libexec --localstatedir=/var --sharedstatedir=/opt/OpenMPI/openmpi-intel-1.1/ib/com --mandir=/usr/share/man --infodir=/usr/share/info --prefix=/opt/OpenMPI/openmpi-intel-1.1/ib --sysconfdir=/opt/OpenMPI/openmpi-intel-1.1/ib/etc --mandir=/opt/OpenMPI/openmpi-intel-1.1/ib/man --disable-shared --enable-static --with-bproc --with-openib=/opt/IB/ibgd-2.0.1