Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

From: Brian Barrett (brbarret_at_[hidden])
Date: 2006-07-04 10:06:46


On Jul 4, 2006, at 1:53 AM, Chengwen Chen wrote:

> Dear openmpi users,
>
> I am using openmpi-1.0.2 on Redhat linux. I can succussfully run
> mpirun in single PC with 2 np. But fail in remote node. Can you
> give me some advices? thank you very much in advance.
>
> [say_at_wolf45 tmp]$ mpirun -np 2 /tmp/test.x
>
> [say_at_wolf45 tmp]$ mpirun -np 2 --host wolf45,wolf46 /tmp/test.x
> say_at_wolf46's password:
> orted: Command not found.
> [wolf45:11357] ERROR: A daemon on node wolf46 failed to start as
> expected.
> [wolf45:11357] ERROR: There may be more information available from
> [wolf45:11357] ERROR: the remote shell (see above).
> [wolf45:11357] ERROR: The daemon exited unexpectedly with status 1.

Kefeng is correct that you should setup your ssh keys so that you
aren't prompted for a password, but that isn't the cause of your
failure. The problem appears to be that orted (one of the Open MPI
commands) is not in your path on the remote node. You should take a
look at one of the other FAQ sections on the setup required for Open
MPI in an rsh/ssh type environment.

   http://www.open-mpi.org/faq/?category=running

Hope this helps,

Brian

-- 
   Brian Barrett
   Open MPI developer
   http://www.open-mpi.org/