Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Jeff Squyres \(jsquyres\) (jsquyres_at_[hidden])
Date: 2006-06-28 09:15:53

This *may* be due to stdio blocking issues (e.g., not getting the password/passphrase to ssh properly, so the application never actually launches on the remote node).
The first thing I would do is find out why you are getting prompted for a password. Open MPI requires that you are not prompted -- check out our FAQ on the issue:
In particular:
Once you get that going, try OMPI's mpirun again and see if it works without hanging. I'd first try launching non-MPI applications such as "hostname" or "uptime". If those work, then try your MPI hello world program.


        From: users-bounces_at_[hidden] [mailto:users-bounces_at_[hidden]] On Behalf Of shen T.T.
        Sent: Wednesday, June 28, 2006 9:09 AM
        To: Open MPI Users
        Subject: Re: [OMPI users] rsh/ssh is work but mpirun hang ?
        If i mpirun the MPI application--'hello world' on a single computer(dual core) itself, it is work. But it can't be successful when i mpirun it across multiple nodes. The rsh/ssh agent is work, i can rsh/ssh to other nodes.Everytime i mpirun 'hostname' , the remote rsh/ssh agent ask for the password.I enter the password but the Openmpi is hang. It is just hang and nothing else.
        I don't know what happen to my Openmpi enviroment or operating system.
        Would you ever encount this problem?

        "Jeff Squyres (jsquyres)" <jsquyres_at_[hidden]> 說:

                Can you provide a little more information?
                What exactly are you trying to mpirun across multiple nodes? Is it an MPI application or a non-MPI application? For example, can you mpirun "hostname" (i.e., the Unix hostname utility) across multiple nodes successfully?
                If you're trying to mpirun a user application, what application is it? Can you mpirun a trivial MPI application (e.g., hello world) successfully?


                        From: users-bounces_at_[hidden] [mailto:users-bounces_at_[hidden]] On Behalf Of shen T.T.
                        Sent: Wednesday, June 21, 2006 11:01 AM
                        To: users_at_[hidden]
                        Subject: [OMPI users] rsh/ssh is work but mpirun hang ?
                        I have installed the openmpi -1.0.2 on the Fedora Core5 operating system. I use the Intel Fortran compiler. I can rsh/ssh to the other processor in our cluster( 2 PC's , 4cores). I can mpirun on a processor itself successfully. When i mpirun on 2 PC's, after entering the password, the program will be hung!
                        Does anyone encounter this problem?How do i check and fix it?
                        Thanks in advance
                        éƒ”陔唳 Yahoo!藻撈籵? 7.0ㄛ轎愐鋒繚??斕湖ㄐ

                users mailing list

        æœ€æ–°ç‰ˆ Yahoo!奇摩即時通訊 7.0,免費網路電話任你打!