Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: George Bosilca (bosilca_at_[hidden])
Date: 2006-06-24 13:19:46


As your cluster have several network devices that are supported by
Open MPI it is possible that the configure script detected the
correct path to their libraries. Therefore, they might be included/
compiled by default in Open MPI. The simplest way to check is to use
the ompi_info tool. "ompi_info | grep btl" will list all the network
devices supported by your particular build.

If several devices (called BTL in Open MPI terms) are compiled in,
only forcing one eth interface for the TCP BTL is not enough. You
should specify that you want only the TCP BTL to be used, forcing
Open MPI to unload/ignore all other available BTL. Add "--mca btl
tcp,self" to your mpirun command and the problem should be solved.

     george.

On Jun 23, 2006, at 10:22 PM, Swamy Kandadai wrote:

>
>
> Dr. Swamy N. Kandadai
> Certified Sr. Consulting IT Specialist
> HPC Benchmark Center
> System & Technology Group, Poughkeepsie, NY
> Phone:( 845) 433 -8429 (8-293) Fax:(845)432-9789
> swamy_at_[hidden]
> http://w3.ibm.com/sales/systems/benchmarks
>
>
>
>
>
> ----- Forwarded by Swamy Kandadai/Poughkeepsie/IBM on 06/23/2006
> 10:21 PM
> -----
>
> Swamy
> Kandadai/Poughkee
> psie/
> IBM To
> users_at_[hidden]
> 06/23/2006
> 09:52 cc
> PM
>
> Subject
> OpenMPI version 1.1
>
>
>
>
>
>
>
>
>
> Hi:
>
> I am trying to run OpenMPI on a couple of nodes. These nodes have
> several
> interfaces: eth0 (which is a GigE),
> eth1 (which is a GigE with Jumbo frames enabled), IpoIB, myr0 in
> addition
> to loopback (l0).
>
> I want to use exclusively eth1 and I am running with this option:
>
> mpirun --mca btl_tcp_if_include eth1 -machinefile hf -np 2 IMB-MPI1
>
> where IMB-MPI1 is the Intel message passing benchmark.
>
> Different times, it has different behaviors:
>
> I ran on one set of nodes and I got a typical GigE behavior (around
> 100
> MB/s). On a different pairs of nodes
> it is giving me the BW consistent with IpoIB (around 700 MB/s).
>
> Can u help me what I am doing wrong? How can I force it to use eth1
> on all
> nodes?
>
> I just built OpenMPI with the following option:
>
> ./configure --prefix=$BINDIR --disable-io-romio
>
> Thanks
> Swamy
>
>
>
> Dr. Swamy N. Kandadai
> Certified Sr. Consulting IT Specialist
> HPC Benchmark Center
> System & Technology Group, Poughkeepsie, NY
> Phone:( 845) 433 -8429 (8-293) Fax:(845)432-9789
> swamy_at_[hidden]
> http://w3.ibm.com/sales/systems/benchmarks
>
>
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users