Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Anoop Rajendra (anoop.rajendra_at_[hidden])
Date: 2006-06-15 16:46:45


Hi,

I'm trying to run a simple pi program compiled using openmpi.

My command line and error message is

[mpiuser_at_Pebble-anoop ~]$ mpirun -n 2 -hostfile /opt/openmpi/openmpi/
etc/openmpi-default-hostfile /home/mpiuser/cpi2
Signal:11 info.si_errno:0(Success) si_code:1(SEGV_MAPERR)
Failing at addr:0x6
*** End of error message ***
[0] func:/opt/openmpi/openmpi/lib/libopal.so.0 [0xceb6dd]
[1] func:/lib/tls/libpthread.so.0 [0xd44880]
[2] func:/opt/openmpi/openmpi/lib/openmpi/mca_btl_tcp.so [0x746d23]
[3] func:/opt/openmpi/openmpi/lib/openmpi/mca_btl_tcp.so
(mca_btl_tcp_add_procs+0x140) [0x744094]
[4] func:/opt/openmpi/openmpi/lib/openmpi/mca_bml_r2.so
(mca_bml_r2_add_procs+0x202) [0x96add6]
[5] func:/opt/openmpi/openmpi/lib/openmpi/mca_pml_ob1.so
(mca_pml_ob1_add_procs+0x85) [0x134259]
[6] func:/opt/openmpi/openmpi/lib/libmpi.so.0(ompi_mpi_init+0x385)
[0x70ca7d]
[7] func:/opt/openmpi/openmpi/lib/libmpi.so.0(MPI_Init+0x8c) [0x6fb724]
[8] func:/home/mpiuser/cpi2(main+0x56) [0x804890d]
[9] func:/lib/tls/libc.so.6(__libc_start_main+0xd3) [0xaf3e23]
[10] func:/home/mpiuser/cpi2 [0x8048819]

The application was compiled with the following command line

[root_at_Pebble-anoop examples]# mpicc -o cpi2 cpi.c

There are 2 single processor machines in the cluster with my host
file reading

pebble-anoop.local
compute-0-0.local

Finally, openMPI was compiled with no special options. Just the
default make all install.

Can someone help me? I'm a newbie at this: so please excuse my
naivete, and I'd be grateful if someone can point me in the right
direction.

Thanks,
Anoop