Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

From: Pak Lui (Pak.Lui_at_[hidden])
Date: 2006-06-13 14:13:48


Hi, I am not sure if it's a real issue or not, but I run a user program
that calls MPI_Comm_spawn to launch on a remote node, the parent
processes got launched via ssh with no problem, but when the child
processes want to launch, I got a message saying that orted is not
found. I've only set my --prefix when I run my spawn job.

If I do the spawn job on local node only, it runs fine. And I can
workaround the issue by manually setting the -mca pls_rsh_orted with the
appropriate path.

But the FAQ says I don't need to put my PATH or LD_LIBRARY_PATH if I
have prefix, so shouldn't the prefix_dir be stashed away for the spawn
child?

======================
on node1, I do mpirun on remote host:

% ./mpirun -np 4 -host node2 -prefix /ompi/trunk/builds/sparc32-g
./mspawn2 -n 1 -C 5 -P 5
Password:
0: ./mspawn2: MPI_APPNUM = 1
2: ./mspawn2: MPI_APPNUM = 1
3: ./mspawn2: MPI_APPNUM = 1
1: ./mspawn2: MPI_APPNUM = 1
Password:
orted: Command not found.
^C^\Quit

-- 
Thanks,
- Pak Lui