Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Jeff Squyres \(jsquyres\) (jsquyres_at_[hidden])
Date: 2006-06-13 10:11:49


This type of error *usually* indicates a programming error, but in this
case, it's so non-specific that it's not entirely clear that this is the
case.

The Vasp code seems to be not entirely open, so I can't try this myself.
Can you try running vasp through a debugger and putting a breakpoint in
MPI_Cart_create? The routine itself is not very long -- you should be
able to step through it and see where it is generating this error.
Having a back trace of where this error is occurring would be extremely
helpful in diagnosing the real problem.

> -----Original Message-----
> From: users-bounces_at_[hidden]
> [mailto:users-bounces_at_[hidden]] On Behalf Of Brock Palen
> Sent: Thursday, June 08, 2006 2:38 PM
> To: Open MPI Users
> Subject: [OMPI users] Errors with MPI_Cart_create
>
> I have build vasp (http://cms.mpi.univie.ac.at/vasp/) for a user
> using openMPI-1.0.2 with teh PGI 6.1 compilers, At runtime I am
> getting the following OMPI errors,
>
> bash-3.00$ mpirun -np 2 vasp
> running on 2 nodes
> [nyx.engin.umich.edu:16167] *** An error occurred in MPI_Cart_create
> [nyx.engin.umich.edu:16167] *** on communicator MPI_COMM_WORLD
> [nyx.engin.umich.edu:16167] *** MPI_ERR_OTHER: known error not in list
> [nyx.engin.umich.edu:16167] *** MPI_ERRORS_ARE_FATAL (goodbye)
>
>
> This is regular OMPI error messages, is this a problem with the
> build? (its very complicated) or with vasp as writen? Or OMPI?
> Direction is very much appreciated.
>
> Brock
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>