Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

From: Jeff Squyres \(jsquyres\) (jsquyres_at_[hidden])
Date: 2006-05-25 18:34:02


Brian gave a much more complete description of the problem than me;
thanks.

We'll have this fixed in v1.0.3 (and later) such that you can use
LDFLAGS / LIBS, as expected, and you will not have to pass -l values
through FCFLAGS (which is quite definitely not the Right place to pass
in -l value).

Note, too, that the 1.1 betas currently do not have good Fortran 90
support -- in an attempt to support the Fortran compilers belonging to
new members of the OMPI team, we managed to break the F90 bindings in
recent betas. :-( We're working now to fix that and hope to have a
beta shortly that includes proper F90 support (much better than it was
in 1.0, actually).

> -----Original Message-----
> From: users-bounces_at_[hidden]
> [mailto:users-bounces_at_[hidden]] On Behalf Of Brian W. Barrett
> Sent: Thursday, May 25, 2006 6:26 PM
> To: Open MPI Users
> Subject: Re: [OMPI users] Fortran support not installing
>
> On Wed, 24 May 2006, Terry Reeves wrote:
>
> There are two sepereate issues at work here.
>
> Unfortunately, g95 as installed is broken and requires the
> -lSystemStubs
> flag to all link commands in order to work properly.
> Normally, one could
> just add -lSystemStubs to LDFLAGS and everything would work fine.
> Unfortunately, there is a bug in the configure tests for Open
> MPI 1.0.x
> that prevents this from working with Fortran 90. Jeff suggested a
> workaround (adding -l in FCFLAGS) that's a really bad idea. A better
> solution would be to use the 1.1 betas (available on the Open MPI web
> page) or to get a copy of g95 that properly links (it has
> been suggested
> that the one from Fink does this properly).
>
> The issue with gfortran is much simpler -- it wasn't found in
> your path
> when you ran configure. Make sure you can run 'gfortran -V'
> and get the
> expected version output, then try re-running configure. My
> guess is that
> your problems will go away. You can also specify a full path
> to gfortran,
> like:
>
> ./configure FC=/usr/local/foo/bin/gfortran
> F77=/usr/local/foo/bin/gfortran
>
> Just make sure you put the right path in ;).
>
> Hope this helps,
>
> Brian
>