Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Ñî¿Æ (semper_at_[hidden])
Date: 2006-05-25 04:54:10


Hi,all
I tried to use hostfile option to launch MPI jobs on several nodes.Each node has
the same Open MPI package installed correctly (version 1.1ra9202).
But only node0 refused to work with other nodes.What should I do?
Can anybody help me? thank you.

[semper_at_node0]mpirun --hostfile h -np 4 /tmp/semper/testMPI
Hello MPI World the original.
Hello MPI World the original.
Hello MPI World the original.
Hello MPI World the original.
Signal:11 info.si_errno:0(Success) si_code:2(SEGV_ACCERR)
Failing at addr:0x6

[semper_at_node0]cat h
node0
node2
node4
node6
[semper_at_node0]vi h
[semper_at_node0]cat h
node2
node4
node6

[semper_at_node0]mpirun --hostfile h -np 4 /tmp/semper/testMPI
Hello MPI World the original.
Hello MPI World the original.
Hello MPI World the original.
Hello MPI World the original.
>From process 0: Num processes: 4
Greetings from process 1 ,pid 5140,host node4!
Greetings from process 2 ,pid 11471,host node6!
Greetings from process 3 ,pid 4290,host node2!

[semper_at_node0]mpirun -np 4 /tmp/semper/testMPI
Hello MPI World the original.
Hello MPI World the original.
Hello MPI World the original.
Hello MPI World the original.
>From process 0: Num processes: 4
Greetings from process 1 ,pid 21743,host node0!
Greetings from process 2 ,pid 21744,host node0!
Greetings from process 3 ,pid 21745,host node0!