Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

From: Brock Palen (brockp_at_[hidden])
Date: 2006-05-24 17:10:28


Im getting the following error when trying to build OMPI on OSX
10.3.9 with myrinet support, the libs are in
/opt/gm/lib
Includes:
/opt/gm/include

Bellow is my configure line and the error:
./configure --prefix=/home/software/openmpi-1.0.2 --with-tm=/home/
software/torque-2.1.0p0 --with-gm=/opt/gm FC=/opt/ibmcmp/xlf/8.1/bin/
xlf90 F77=/opt/ibmcmp/xlf/8.1/bin/xlf CPPFLAGS=-I/opt/gm/include

gcc -DHAVE_CONFIG_H -I. -I. -I../../../../include -I../../../../
include -I/opt/gm/include -I../../../../include -I../../../.. -
I../../../.. -I../../../../include -I../../../../opal -I../../../../
orte -I../../../../ompi -I/opt/gm/include -D_REENTRANT -O3 -DNDEBUG -
fno-strict-aliasing -MT ptl_gm.lo -MD -MP -MF .deps/ptl_gm.Tpo -c
ptl_gm.c -fno-common -DPIC -o .libs/ptl_gm.o
gcc -DHAVE_CONFIG_H -I. -I. -I../../../../include -I../../../../
include -I/opt/gm/include -I../../../../include -I../../../.. -
I../../../.. -I../../../../include -I../../../../opal -I../../../../
orte -I../../../../ompi -I/opt/gm/include -D_REENTRANT -O3 -DNDEBUG -
fno-strict-aliasing -MT ptl_gm_priv.lo -MD -MP -MF .deps/
ptl_gm_priv.Tpo -c ptl_gm_priv.c -fno-common -DPIC -o .libs/
ptl_gm_priv.o
ptl_gm_component.c: In function `mca_ptl_gm_thread_progress':
ptl_gm_component.c:249: error: `PTHREAD_CANCELED' undeclared (first
use in this function)
ptl_gm_component.c:249: error: (Each undeclared identifier is
reported only once
ptl_gm_component.c:249: error: for each function it appears in.)
make[4]: *** [ptl_gm_component.lo] Error 1
make[4]: *** Waiting for unfinished jobs....
make[3]: *** [all-recursive] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all-recursive] Error 1

Could this be related to the version of the gm package we have
installed? Any insight would be helpful.
Brock