Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Jeff Squyres \(jsquyres\) (jsquyres_at_[hidden])
Date: 2006-05-24 06:30:48


Blast! How embarrassing. I missed that one last night in my haste to
fix the problem.

Thanks...

> -----Original Message-----
> From: users-bounces_at_[hidden]
> [mailto:users-bounces_at_[hidden]] On Behalf Of Bert Wesarg
> Sent: Wednesday, May 24, 2006 2:15 AM
> To: Open MPI Users
> Subject: Re: [OMPI users] wrong predefined MPI_PROD
>
> hello,
>
> i see the fix, but why isn't line 339 changed?
>
> https://svn.open-mpi.org/trac/ompi/browser/trunk/ompi/op/op_pr
> edefined.c?rev=10023#L339
>
> bert
>
> On Tue, 23 May 2006, Brian Barrett wrote:
>
> > On May 23, 2006, at 11:49 AM, Bert Wesarg wrote:
> >
> > > Hello,
> > >
> > > the predfined mpi op MPI_PROD is apparently wrong:
> > >
> > > from openmpi-1.2a1r10020/ompi/op/op_predefined.c:
> > >
> > > OP_FUNC(prod, long_long_int, long long int, +=)
> > > OP_FUNC(prod, unsigned_long_long, unsigned long long, +=)
> > > :
> > > OP_FUNC(prod, fortran_integer1, ompi_fortran_integer1_t, +=)
> > > :
> > > OP_FUNC(prod, fortran_integer2, ompi_fortran_integer2_t, +=)
> > > :
> > > OP_FUNC(prod, fortran_integer4, ompi_fortran_integer4_t, +=)
> > > :
> > > :
> >
> > Doh! Thanks for finding that. We'll have a fix in shortly,
> > definitely before 1.1 releases.
> >
> > I've filed a bug report in our tracker, and you should get e-mail
> > updates when the bug is fixed.
> >
> > Brian
> > _______________________________________________
> > users mailing list
> > users_at_[hidden]
> > http://www.open-mpi.org/mailman/listinfo.cgi/users
> >
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>