Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Brian Barrett (brbarret_at_[hidden])
Date: 2006-05-17 22:15:40


On May 1, 2006, at 7:16 PM, Jeffrey Fox wrote:

> I get openmpi-1.0.2 to compile on a (small) G5 cluster. The C and C+
> + compilers work fine so far, but the mpif77 and mpif90 scripts
> send the wrong flags to the f77 and f90 compilers. I've attached
> the config.log , make.out, the error
> messages, and the environment variables.
> for f77 I get :Error: bad option: -Wl,--export-dynamic
> and for f90 :
> cf90-78 f90fe: ERROR in command line
> -N option has an illegal argument "l,--export-dynamic".
> f90fe-912: 1 Errors found in command line. Compilation aborted.
>
> I feel I am soooo close. :-)
Sorry about the delay in replying -- for some reason, this message
slipped through the cracks. Anyway, the problem is that older
versions of the Absoft compilers didn't speak the same language as
other compilers in the OS X (and general Unix) world. In particular,
they didn't know that -Wl, meant the rest of the option should be
passed to the linker as an argument when the compiler invoked the
linker. Absoft has since updated their compilers to fix the issue,
so upgrading the compilers will fix the issue.

The other option is to just not do anything that requires special
flags to the linker. This means disabling our dynamically loaded
components (and having them compiled into libmpi.so) and turing off
some code we have for high-performance networks (Myrinet and
InfiniBand, in particular). Adding the configure options:

   --without-memory-manager --disable-dlopen

Should give you a build that will avoid passing arguments that will
annoy the Absoft compiler.

Hope this helps,

Brian

-- 
   Brian Barrett
   Open MPI developer
   http://www.open-mpi.org/