Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Jeff Squyres \(jsquyres\) (jsquyres_at_[hidden])
Date: 2006-05-17 07:54:25


Many thanks for following up to the list with this information.

________________________________

        From: users-bounces_at_[hidden]
[mailto:users-bounces_at_[hidden]] On Behalf Of W. Bryan Smith
        Sent: Wednesday, May 17, 2006 12:23 AM
        To: users_at_[hidden]
        Subject: Re: [OMPI users] ParaView runtime problem with openmpi
1.0.2
        
        
        to successfully build ParaView with OpenMPI support in Linux:
        
        1) compile OpenMPI and add openmpi/bin/ to the top of your PATH
and add openmpi/lib/ to the top of the LD_LIBRARY_PATH environment
variable. this is in my .cshrc so they are always set whenever i log
in.
        
        2) download the ParaView source (paraview.org)
        
        3) edit CMakeLists.txt in the ParaView source directory to
specify the MPI C and C++ compilers:
        
        SET(CMAKE_C_COMPILER mpicc)
        SET(CMAKE_CXX_COMPILER mpicxx)
        
        4) make a ParaView build directory and cd to the new dir
(ParaView requires out-of-source builds)
        
        5) configure the ParaView make using cmake as follows:
        
        cmake -DVTK_USE_MPI:BOOL=ON \
        -DVTK_MPIRUN_EXE:FILEPATH=/path_to_openmpi1.0.2/bin/mpirun \
        
        /path_to_paraview_src/

        6) once the configure is complete (lots of text dumped to the
screen), you should be able to make the binaries (from within the
paraview build directory):
        
        make
        
        Now you can run ParaView in parallel mode using:
        
        mpiexec -n NP /path_to_paraview_build/bin/./paraview
        
        where NP = desired number of processes.
        happy parallel volume rendering...
        
        bryan
        
        
        On 5/11/06, W. Bryan Smith <wbsmith_at_[hidden]> wrote:

                hi,
                
                i have compiled a program called ParaView (paraview.org)
with MPI support using OpenMPI 1.0.2, and when i try to run the paraview
executable using
                
                mpiexec -n 4 paraview
                
                or
                
                miprun -np 4 paraview
                
                instead of having one paraview window open with parallel
support, there are 4 paraview windows opened, none of which are running
with parallel support. attached are the ompi_info and config.log files.
below is the text of the cmake call i used to configure paraview:
                
                cmake -DVTK_USE_MPI:BOOL=ON
                -DMPI_INCLUDE_PATH:PATH=/local2/openmpi1.0.2/include/
                
        
-DVTK_MPIRUN_EXE:FILEPATH=/local2/openmpi1.0.2/bin/mpirun
        
-DMPI_LIBRARY:FILEPATH=/local2/openmpi1.0.2/lib/libmpicxx.la
                /local2/paraview-2.4.3/
                
                i also edited the ParaView CMakeLists.txt file to
contain:
                SET(CMAKE_C_COMPILER mpicc)
                SET(CMAKE_CXX_COMPILER mpicxx)
                
                both compiler wrappers are on the top of my PATH. also,
as far as PATH goes, yes, i am certain that the mpiexec and paraview
binaries are the ones i think they are ( i.e. when I WHICH MPIEXEC it
only shows the one i compiled locally, etc).
                
                anyone have any insight on this? for the record, when i
compile paraview with MPI support using mpich2 (1.0.3), and then do
mpiexec calling that version of paraview, i get the expected behavior (
i.e. one paraview window running with parallel support).
                
                thanks in advance,
                bryan smith